Intermittent Outbound and Inbound Calls Failing
Incident Report for Ring.io
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 13:56 EDT
Identified
We are currently experiencing issues with inbound and outbound calls failing. Our engineers are investigating the issue.
Posted Apr 22, 2024 - 11:39 EDT
This incident affected: Ring.io Service.